Browse Source

meta: genext2fs is no longer required (but still useful)

K. Lange 1 year ago
parent
commit
0f9e847c92
2 changed files with 2 additions and 12 deletions
  1. 2 2
      README.md
  2. 0 10
      util/check-reqs.sh

File diff suppressed because it is too large
+ 2 - 2
README.md


+ 0 - 10
util/check-reqs.sh

@@ -7,16 +7,6 @@ if ! which python3 >/dev/null; then
     RET=1
 fi
 
-if ! which genext2fs >/dev/null; then
-    echo "genext2fs is needed to build ramdisk images"
-    RET=1
-else
-    if [ -z "$(genext2fs --help 2>&1 | grep -- "block-size")" ]; then
-        echo "genext2fs must support the -B (--block-size) argument; try building with Debian patches"
-        RET=1
-    fi
-fi
-
 if ! which mkfs.fat >/dev/null; then
     echo "mkfs.fat is required (and should be in your PATH) to build EFI file systems"
     RET=1